Fortinet FortiOS 5.2.x < 5.2.11 srcintf XSS (FG-IR-17-017)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote host is affected by a cross-site scripting vulnerability.

Description :

The version of Fortinet FortiOS running on the remote FortiGate device
is 5.2.x prior to 5.2.11. It is, therefore, affected by a cross-site
scripting (XSS) vulnerability when creating firewall policies due to
improper validation of input related to srcintf before returning it to
users. An authenticated, remote attacker can exploit this, via a
specially crafted request, to execute arbitrary script code in a
user's browser session.

See also :

http://fortiguard.com/psirt/FG-IR-17-017

Solution :

Upgrade to Fortinet FortiOS version 5.2.11 or later.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 2.9
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Firewalls

Nessus Plugin ID: 99969 ()

Bugtraq ID: 98048

CVE ID: CVE-2017-3127

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now