EulerOS 2.0 SP2 : libguestfs (EulerOS-SA-2017-1061)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote EulerOS host is missing a security update.

Description :

According to the version of the libguestfs packages installed, the
EulerOS installation on the remote host is affected by the following
vulnerability :

- OCaml before 4.03.0 does not properly handle sign
extensions, which allows remote attackers to conduct
buffer overflow attacks or obtain sensitive information
as demonstrated by a long string to the String.copy
function.(CVE-2015-8869)

Note that Tenable Network Security has extracted the preceding
description block directly from the EulerOS security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

http://www.nessus.org/u?518c358f

Solution :

Update the affected libguestfs package.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P)
CVSS Temporal Score : 5.0
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Huawei Local Security Checks

Nessus Plugin ID: 99908 ()

Bugtraq ID:

CVE ID: CVE-2015-8869

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now