EulerOS 2.0 SP1 : memcached (EulerOS-SA-2016-1086)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote EulerOS host is missing multiple security updates.

Description :

According to the versions of the memcached package installed, the
EulerOS installation on the remote host is affected by the following
vulnerabilities :

- Two integer overflow flaws, leading to heap-based
buffer overflows, were found in the memcached binary
protocol. An attacker could create a specially crafted
message that would cause the memcached server to crash
or, potentially, execute arbitrary code.
(CVE-2016-8704, CVE-2016-8705)

- An integer overflow flaw, leading to a heap-based
buffer overflow, was found in memcached's parsing of
SASL authentication messages. An attacker could create
a specially crafted message that would cause the
memcached server to crash or, potentially, execute
arbitrary code.(CVE-2016-8706)

Note that Tenable Network Security has extracted the preceding
description block directly from the EulerOS security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

http://www.nessus.org/u?7d42132f

Solution :

Update the affected memcached packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.9
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Huawei Local Security Checks

Nessus Plugin ID: 99845 ()

Bugtraq ID:

CVE ID: CVE-2016-8704
CVE-2016-8705
CVE-2016-8706

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now