openSUSE Security Update : libsndfile (openSUSE-2017-514)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for libsndfile fixes the following security issues :

- CVE-2017-7586: A stack-based buffer overflow via a
specially crafted FLAC file was fixed (error in the
'header_read()' function) (bsc#1033053)

- CVE-2017-7585,CVE-2017-7741, CVE-2017-7742: Several
stack-based buffer overflows via a specially crafted
FLAC file (error in the 'flac_buffer_copy()' function)
were fixed (bsc#1033054,bsc#1033915,bsc#1033914).

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1033053
https://bugzilla.opensuse.org/show_bug.cgi?id=1033054
https://bugzilla.opensuse.org/show_bug.cgi?id=1033914
https://bugzilla.opensuse.org/show_bug.cgi?id=1033915

Solution :

Update the affected libsndfile packages.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 99703 ()

Bugtraq ID:

CVE ID: CVE-2017-7585
CVE-2017-7586
CVE-2017-7741
CVE-2017-7742

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now