FreeBSD : codeigniter -- multiple vulnerabilities (df0144fb-295e-11e7-970f-002590263bf5)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote FreeBSD host is missing a security-related update.

Description :

The CodeIgniter changelog reports :

Fixed a header injection vulnerability in common function
set_status_header() under Apache (thanks to Guillermo Caminer from
Flowgate).

Fixed byte-safety issues in Encrypt Library (DEPRECATED) when
mbstring.func_overload is enabled.

Fixed byte-safety issues in Encryption Library when
mbstring.func_overload is enabled.

Fixed byte-safety issues in compatibility functions password_hash(),
hash_pbkdf2() when mbstring.func_overload is enabled.

Updated Encrypt Library (DEPRECATED) to call mcrypt_create_iv() with
MCRYPT_DEV_URANDOM.

See also :

https://www.codeigniter.com/user_guide/changelog.html
http://www.nessus.org/u?2031f286

Solution :

Update the affected package.

Risk factor :

High

Family: FreeBSD Local Security Checks

Nessus Plugin ID: 99647 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now