VMware Workstation 12.x < 12.5.3 Multiple Vulnerabilities (VMSA-2017-0008)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A virtualization application installed on the remote Windows host is
affected by multiple vulnerabilities.

Description :

The version of VMware Workstation installed on the remote Windows host
is 12.x prior to 12.5.3. It is, therefore, affected by multiple
vulnerabilities :

- A heap buffer overflow condition exists in the Cortado
ThinPrint component, specifically within TPView.dll,
due to improper validation of certain input when parsing
JPEG2000 files. An attacker on the guest can exploit
this to cause a denial of service condition or the
execution or arbitrary code on the host system.
(CVE-2017-4908)

- A heap buffer overflow condition exists in the Cortado
ThinPrint component, specifically within TPView.dll,
due to improper validation of certain input when parsing
TrueType Fonts. An attacker on the guest can exploit
this to cause a denial of service condition or the
execution or arbitrary code on the host system.
(CVE-2017-4909)

- Out-of-bounds read and write errors exist in the Cortado
ThinPrint component, specifically within TPView.dll,
due to improper validation of certain input when parsing
JPEG2000 files. An attacker on the guest can exploit
these to corrupt memory, resulting in a denial of
service condition or the execution of arbitrary code on
the host system. (CVE-2017-4910, CVE-2017-4911)

- Out-of-bounds read and write errors exist in the Cortado
ThinPrint component, specifically within TPView.dll,
due to improper validation of certain input when parsing
TrueType Fonts. An attacker on the guest can exploit
these to corrupt memory, resulting in a denial of service
condition or the execution of arbitrary code on the host
system. (CVE-2017-4912)

- An integer overflow condition exists in the Cortado
ThinPrint component, specifically within TPView.dll,
due to improper validation of certain input when parsing
TrueType Fonts. An attacker on the guest can exploit
this to corrupt memory, resulting in a denial of service
condition or the execution of arbitrary code on the host
system. (CVE-2017-4913)

The above vulnerabilities can be exploited only if virtual printing
has been enabled. This feature is not enabled by default on VMware
Workstation.

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://www.vmware.com/security/advisories/VMSA-2017-0008.html

Solution :

Upgrade to VMware Workstation version 12.5.3 or later.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.1
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now