openSUSE Security Update : gstreamer-plugins-good (openSUSE-2017-495)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for gstreamer-plugins-good fixes the following issues :

- A crafted aac audio file could have caused an invalid
read and thus corruption or denial of service
(bsc#1024014, CVE-2016-10198)

- A crafted mp4 file could have caused an invalid read and
thus corruption or denial of service (bsc#1024017,
CVE-2016-10199)

- A crafted avi file could have caused an invalid read and
thus corruption or denial of service (bsc#1024034,
CVE-2017-5840)

- A crafted AVI file with metadata tag entries (ncdt)
could have caused invalid read access and thus
corruption or denial of service (bsc#1024030,
CVE-2017-5841)

- A crafted avi file could have caused an invalid read
access resulting in denial of service (bsc#1024062,
CVE-2017-5845)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1024014
https://bugzilla.opensuse.org/show_bug.cgi?id=1024017
https://bugzilla.opensuse.org/show_bug.cgi?id=1024030
https://bugzilla.opensuse.org/show_bug.cgi?id=1024034
https://bugzilla.opensuse.org/show_bug.cgi?id=1024062

Solution :

Update the affected gstreamer-plugins-good packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 99560 ()

Bugtraq ID:

CVE ID: CVE-2016-10198
CVE-2016-10199
CVE-2017-5840
CVE-2017-5841
CVE-2017-5845

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now