Oracle WebLogic Server Multiple Vulnerabilities (April 2017 CPU)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An application server installed on the remote host is affected by
multiple vulnerabilities.

Description :

The version of Oracle WebLogic Server installed on the remote host is
affected by multiple vulnerabilities :

- A remote code execution vulnerability exists in the
Apache Struts component due to improper handling of
multithreaded access to an ActionForm instance. An
unauthenticated, remote attacker can exploit this, via a
specially crafted multipart request, to execute
arbitrary code or cause a denial of service condition.
(CVE-2016-1181)

- An unspecified flaw exists in the Web Services
subcomponent that allows an unauthenticated, remote
attacker to modify or delete arbitrary data accessible
to the server. (CVE-2017-3506)

- A remote code execution vulnerability exists in the Web
Container subcomponent due to improper handling of
reflected PartItem File requests. An unauthenticated,
remote attacker can exploit this, via a specially
crafted request, to execute arbitrary code.
(CVE-2017-3531)

- A remote code execution vulnerability exists in the
Apache Struts component in the Jakarta Multipart parser
due to improper handling of the Content-Type,
Content-Disposition, and Content-Length headers.
An unauthenticated, remote attacker can exploit this,
via a specially crafted header value in the HTTP
request, to execute arbitrary code. (CVE-2017-5638)

See also :

http://www.nessus.org/u?623d2c22
http://www.nessus.org/u?08e1362c
https://support.oracle.com/rs?type=doc&id=2228898.1
https://www.tenable.com/security/research/tra-2017-16
http://www.zerodayinitiative.com/advisories/ZDI-16-444/
http://blog.talosintelligence.com/2017/03/apache-0-day-exploited.html
http://www.nessus.org/u?77e9c654

Solution :

Apply the appropriate patch according to the April 2017 Oracle
Critical Patch Update advisory.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 8.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 99528 ()

Bugtraq ID: 91068
91787
96729
97884

CVE ID: CVE-2016-1181
CVE-2017-3506
CVE-2017-3531
CVE-2017-5638

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now