VMware vCenter Server 6.0.x < 6.0u3b / 6.5.x < 6.5c BlazeDS AMF3 RCE (VMSA-2017-0007)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A virtualization management application installed on the remote host
is affected by a remote code execution vulnerability.

Description :

The version of VMware vCenter Server installed on the remote host is
6.0.x prior to 6.0u3b or 6.5.x prior to 6.5c. It is, therefore,
affected by a flaw in FlexBlazeDS when processing AMF3 messages due to
allowing the instantiation of arbitrary classes when deserializing
objects. An unauthenticated, remote attacker can exploit this, by
sending a specially crafted Java object, to execute arbitrary code.

See also :

https://www.vmware.com/security/advisories/VMSA-2017-0007.html
http://www.nessus.org/u?4e032520
http://www.nessus.org/u?4a1fa223
http://codewhitesec.blogspot.de/2017/04/amf.html

Solution :

Upgrade to VMware vCenter Server version 6.0u3b (6.0.0 build-5326177)
/ 6.0u3b on Windows (6.0.0 build-5318198) / 6.5.0c (6.5.0
build-5318112) or later. Alternatively, apply the vendor-supplied
workaround.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Misc.

Nessus Plugin ID: 99475 ()

Bugtraq ID: 97383

CVE ID: CVE-2017-5641

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now