openSUSE Security Update : jasper (openSUSE-2017-478)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for jasper fixes the following issues :

Security issues fixed :

- CVE-2016-9600: NULL pointer Dereference due to missing
check for UNKNOWN color space in JP2 encoder
(bsc#1018088)

- CVE-2016-10251: Use of uninitialized value in
jpc_pi_nextcprl (jpc_t2cod.c) (bsc#1029497)

- CVE-2017-5498: left-shift undefined behaviour
(bsc#1020353)

- CVE-2017-6850: NULL pointer dereference in
jp2_cdef_destroy (jp2_cod.c) (bsc#1021868)

- CVE-2016-9583: Out of bounds heap read in
jpc_pi_nextpcrl() (bsc#1015400)

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1015400
https://bugzilla.opensuse.org/show_bug.cgi?id=1018088
https://bugzilla.opensuse.org/show_bug.cgi?id=1020353
https://bugzilla.opensuse.org/show_bug.cgi?id=1021868
https://bugzilla.opensuse.org/show_bug.cgi?id=1029497

Solution :

Update the affected jasper packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 99429 ()

Bugtraq ID:

CVE ID: CVE-2016-10251
CVE-2016-9583
CVE-2016-9600
CVE-2017-5498
CVE-2017-6850

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now