openSUSE Security Update : tigervnc (openSUSE-2017-475)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for tigervnc provides the several fixes.

These security issues were fixed :

- CVE-2017-7392, CVE-2017-7396: Client can cause leak in
VNC server (bsc#1031886)

- CVE-2017-7395: Authenticated VNC client can crash VNC
server (bsc#1031877)

- CVE-2017-7394: Client can crash or block VNC server
(bsc#1031879)

- CVE-2017-7393: Authenticated client can cause double
free in VNC server (bsc#1031875)

- Prevent buffer overflow in VNC client, allowing for
crashing the client (bnc#1032880)

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1031875
https://bugzilla.opensuse.org/show_bug.cgi?id=1031877
https://bugzilla.opensuse.org/show_bug.cgi?id=1031879
https://bugzilla.opensuse.org/show_bug.cgi?id=1031886
https://bugzilla.opensuse.org/show_bug.cgi?id=1032880

Solution :

Update the affected tigervnc packages.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 99426 ()

Bugtraq ID:

CVE ID: CVE-2017-7392
CVE-2017-7393
CVE-2017-7394
CVE-2017-7395
CVE-2017-7396

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now