Adobe Flash Player for Mac <= 25.0.0.127 Multiple Vulnerabilities (APSB17-10)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote macOS or Mac OS X host has a browser plugin installed that
is affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote macOS or Mac
OS X host is equal or prior to version 25.0.0.127. It is, therefore,
affected by multiple vulnerabilities :

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-3058, CVE-2017-3059, CVE-2017-3062,
CVE-2017-3063)

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-3060, CVE-2017-3061, CVE-2017-3064)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-10.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 25.0.0.148 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 99284 ()

Bugtraq ID: 97551
97557

CVE ID: CVE-2017-3058
CVE-2017-3059
CVE-2017-3060
CVE-2017-3061
CVE-2017-3062
CVE-2017-3063
CVE-2017-3064

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now