openSUSE Security Update : pidgin (openSUSE-2017-431)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for pidgin fixes the following issues :

Feature update :

- Update to GNOME 3.20.2 (fate#318572).

Security issues fixed :

- CVE-2017-2640: Fix an out of bounds memory read in
purple_markup_unescape_entity. (boo#1028835)

- CVE-2014-3698: remote information leak via crafted XMPP
message (boo#902408).

- CVE-2014-3696: denial of service parsing Groupwise
server message (boo#902410).

- CVE-2014-3695: crash in MXit protocol plug-in
(boo#902409).

Bugfixes

- Correctly remove *.so files for plugins (fixes
devel-file-in-non-devel-package).

- Remove generation of a plugin list to package, simply
add it all in %files with exclusions.

- Build with GStreamer 1.x on SLE 12 SP2.

- Fix SASL EXTERNAL fingerprint authentication
(boo#1009974).

- Use ALSA as default for avoiding broken volume control
of pa sink (boo#886670).

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1009974
https://bugzilla.opensuse.org/show_bug.cgi?id=1028835
https://bugzilla.opensuse.org/show_bug.cgi?id=886670
https://bugzilla.opensuse.org/show_bug.cgi?id=902408
https://bugzilla.opensuse.org/show_bug.cgi?id=902409
https://bugzilla.opensuse.org/show_bug.cgi?id=902410
https://features.opensuse.org/318572

Solution :

Update the affected pidgin packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 99194 ()

Bugtraq ID:

CVE ID: CVE-2014-3695
CVE-2014-3696
CVE-2014-3698
CVE-2017-2640

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now