VMware Workstation 12.x < 12.5.5 Multiple Vulnerabilities (VMSA-2017-0006)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A virtualization application installed on the remote Windows host is
affected by multiple vulnerabilities.

Description :

The version of VMware Workstation installed on the remote Windows host
is 12.x prior to 12.5.5. It is, therefore, affected by multiple
vulnerabilities :

- A heap buffer overflow condition exists due to improper
validation of certain input. An attacker on the guest
can exploit this to cause a denial of service condition
or the execution of arbitrary code on the host.
(CVE-2017-4902)

- A stack memory initialization flaw exists that allows an
attacker on the guest to execute arbitrary code on the
host. (CVE-2017-4903)

- An unspecified flaw exists in memory initialization that
allows an attacker on the guest to execute arbitrary
code on the host. (CVE-2017-4904)

- An unspecified flaw exists in memory initialization that
allows the disclosure of sensitive information.
(CVE-2017-4905)

See also :

https://www.vmware.com/security/advisories/VMSA-2017-0006.html

Solution :

Upgrade to VMware Workstation version 12.5.5 or later.

Risk factor :

High / CVSS Base Score : 8.3
(CVSS2#AV:A/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 99105 ()

Bugtraq ID: 97160
97163
97164
97165

CVE ID: CVE-2017-4902
CVE-2017-4903
CVE-2017-4904
CVE-2017-4905

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now