VMware Workstation 12.x < 12.5.3 Multiple Vulnerabilities (VMSA-2017-0003)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

A virtualization application installed on the remote host is affected
by multiple vulnerabilities.

Description :

The version of VMware Workstation installed on the remote host is
12.x prior to 12.5.3. It is, therefore, affected by multiple
vulnerabilities :

- A flaw exists in the vmware-vmx process when loading
dynamic link library (DLL) files due to searching an
insecure path, which was defined in a local environment
variable. A local attacker can exploit this, via a
specially crafted file injected into the path, to
execute arbitrary code with SYSTEM privileges on the
host. (CVE-2017-4898)

- An out-of-bounds read error exists in the SVGA driver
due to improper validation of certain input. A local
attacker can exploit this within a VM to crash it or
to disclose sensitive memory contents. (CVE-2017-4899)

- A NULL pointer dereference flaw exists in the SVGA
driver due to improper validation of certain input. A
local attacker can exploit this within a VM to crash it.
(CVE-2017-4900)

See also :

http://www.vmware.com/security/advisories/VMSA-2017-0003.html

Solution :

Upgrade to VMware Workstation version 12.5.3 or later.

Risk factor :

Medium / CVSS Base Score : 6.9
(CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 5.1
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 97834 ()

Bugtraq ID: 96770
96771
96772

CVE ID: CVE-2017-4898
CVE-2017-4899
CVE-2017-4900

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now