IBM WebSphere Application Server 7.0 < 7.0.0.43 / 8.0 < 8.0.0.14 / 8.5 < 8.5.5.12 / 9.0 < 9.0.0.3 Admin Console Multiple XSS

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote web application server is affected by multiple XSS
vulnerabilities.

Description :

The IBM WebSphere Application Server running on the remote host is
version 7.0 prior to 7.0.0.43, 8.0 prior to 8.0.0.14, 8.5 prior to
8.5.5.12, or 9.0 prior to 9.0.0.3. It is, therefore, affected by
multiple cross-site scripting (XSS) vulnerabilities in the Admin
Console due to a failure to validate input before returning it to
users. An authenticated, remote attacker can exploit these, via a
specially crafted URL, to execute arbitrary script code in a user's
browser session within the security context of the hosting website.

Note that Nessus has not checked for the Interim Fix for these issues
but has instead relied only on the application's self-reported version
number.

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21992315
http://www-01.ibm.com/support/docview.wss?uid=swg21997743
http://www-01.ibm.com/support/docview.wss?uid=swg24043318

Solution :

Apply IBM WebSphere Application Server version 7.0 Fix Pack 43
(7.0.0.43) / 8.0 Fix Pack 14 (8.0.0.14) / 8.5 Fix Pack 12 (8.5.5.12) /
9.0 Fix Pack 3 (9.0.0.3) or later. Alternatively, upgrade to the
minimal fix pack levels required by the interim fix and then apply
Interim Fix PI73367. See the vendor advisory for more details.

Risk factor :

Low / CVSS Base Score : 3.5
(CVSS2#AV:N/AC:M/Au:S/C:N/I:P/A:N)
CVSS Temporal Score : 2.9
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 97355 ()

Bugtraq ID: 95154
96164

CVE ID: CVE-2016-8934
CVE-2017-1121

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now