SUSE SLED12 Security Update : flash-player (SUSE-SU-2017:0523-1)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote SUSE host is missing one or more security updates.

Description :

The Adobe flash-player was updated to 24.0.0.221 to fix the following
issues: Security update to 24.0.0.221 (bsc#1025258), fixing the
following vulnerabilities advised under APSB17-04 :

- type confusion vulnerability that could lead to code
execution (CVE-2017-2995).

- integer overflow vulnerability that could lead to code
execution (CVE-2017-2987).

- use-after-free vulnerabilities that could lead to code
execution (CVE-2017-2982, CVE-2017-2985, CVE-2017-2993,
CVE-2017-2994).

- heap buffer overflow vulnerabilities that could lead to
code execution (CVE-2017- 2984, CVE-2017-2986,
CVE-2017-2992).

- memory corruption vulnerabilities that could lead to
code execution (CVE-2017-2988, CVE-2017-2990,
CVE-2017-2991, CVE-2017-2996).

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

https://bugzilla.suse.com/1025258
https://www.suse.com/security/cve/CVE-2017-2982.html
https://www.suse.com/security/cve/CVE-2017-2985.html
https://www.suse.com/security/cve/CVE-2017-2986.html
https://www.suse.com/security/cve/CVE-2017-2987.html
https://www.suse.com/security/cve/CVE-2017-2988.html
https://www.suse.com/security/cve/CVE-2017-2990.html
https://www.suse.com/security/cve/CVE-2017-2991.html
https://www.suse.com/security/cve/CVE-2017-2992.html
https://www.suse.com/security/cve/CVE-2017-2993.html
https://www.suse.com/security/cve/CVE-2017-2994.html
https://www.suse.com/security/cve/CVE-2017-2995.html
https://www.suse.com/security/cve/CVE-2017-2996.html
http://www.nessus.org/u?a5f6eaa5

Solution :

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Workstation Extension 12-SP1:zypper in -t patch
SUSE-SLE-WE-12-SP1-2017-268=1

SUSE Linux Enterprise Desktop 12-SP1:zypper in -t patch
SUSE-SLE-DESKTOP-12-SP1-2017-268=1

To bring your system up-to-date, use 'zypper patch'.

Risk factor :

Critical / CVSS Base Score : 10.0
(CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.8
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now