Acme thttpd < 2.26 Multiple Vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote server is affected by multiple vulnerabilities.

Description :

According to its banner, the version of Acme thttpd server running
on the remote host is prior to 2.26. It is, therefore, affected by
multiple vulnerabilities :

- Multiple buffer overflow conditions exist in the
htpasswd utility. A local attacker can exploit these,
by calling htpasswd and supplying arbitrary commands
along with a username to be added to the password file,
to bypass required authentication and execute arbitrary
programs with elevated privileges. (CVE-2006-1078)

- A flaw exists in htpasswd that allows a local attacker
to gain privileges via shell metacharacters in a command
line argument, which can then be used to execute other
commands. (CVE-2006-1079)

- An unspecified flaw exists that allows a local attacker
to create or touch arbitrary files via a symlink attack
on the start_thttpd temporary file. (CVE-2006-4248)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

http://www.acme.com/software/thttpd

Solution :

Upgrade to Acme thttpd version 2.26 or later.

Risk factor :

Medium / CVSS Base Score : 4.6
(CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 4.0
(CVSS2#E:H/RL:OF/RC:C)
Public Exploit Available : true

Family: Web Servers

Nessus Plugin ID: 97144 ()

Bugtraq ID: 16972
20891

CVE ID: CVE-2006-1078
CVE-2006-1079
CVE-2006-4248

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now