Adobe Flash Player for Mac <= 24.0.0.194 Multiple Vulnerabilities (APSB17-04)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote macOS or Mac OS X host has a browser plugin installed that
is affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote macOS or Mac
OS X host is equal or prior to version 24.0.0.194. It is, therefore,
affected by multiple vulnerabilities :

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-2982, CVE-2017-2985, CVE-2017-2993,
CVE-2017-2994).

- Multiple heap buffer overflow conditions exist that
allow an unauthenticated, remote attacker to execute
arbitrary code. (CVE-2017-2984, CVE-2017-2986,
CVE-2017-2992).

- An integer overflow condition exists that allows an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-2987).

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-2988, CVE-2017-2990, CVE-2017-2991,
CVE-2017-2996).

- A type confusion error exists that allows an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-2995)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-04.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 24.0.0.221 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now