openSUSE Security Update : gnutls (openSUSE-2017-207)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for gnutls fixes the following security issues :

- GnuTLS could have crashed when processing maliciously
crafted OpenPGP certificates (GNUTLS-SA-2017-2,
bsc#1018832, CVE-2017-5335, CVE-2017-5337,
CVE-2017-5336)

- GnuTLS could have falsely accepted certificates when
using OCSP (GNUTLS-SA-2016-3, bsc#999646, CVE-2016-7444)

- GnuTLS could have suffered from 100% CPU load DoS
attacks by using SSL alert packets during the handshake
(bsc#1005879, CVE-2016-8610)

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1005879
https://bugzilla.opensuse.org/show_bug.cgi?id=1018832
https://bugzilla.opensuse.org/show_bug.cgi?id=999646

Solution :

Update the affected gnutls packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 97004 ()

Bugtraq ID:

CVE ID: CVE-2016-7444
CVE-2016-8610
CVE-2017-5335
CVE-2017-5336
CVE-2017-5337

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now