SUSE SLED12 / SLES12 Security Update : gnutls (SUSE-SU-2017:0348-1)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote SUSE host is missing one or more security updates.

Description :

This update for gnutls fixes the following security issues :

- GnuTLS could have crashed when processing maliciously
crafted OpenPGP certificates (GNUTLS-SA-2017-2,
bsc#1018832, CVE-2017-5335, CVE-2017-5337,
CVE-2017-5336)

- GnuTLS could have falsely accepted certificates when
using OCSP (GNUTLS-SA-2016-3, bsc#999646, CVE-2016-7444)

- GnuTLS could have suffered from 100% CPU load DoS
attacks by using SSL alert packets during the handshake
(bsc#1005879, CVE-2016-8610)

Note that Tenable Network Security has extracted the preceding
description block directly from the SUSE security advisory. Tenable
has attempted to automatically clean and format it as much as possible
without introducing additional issues.

See also :

https://bugzilla.suse.com/1005879
https://bugzilla.suse.com/1018832
https://bugzilla.suse.com/999646
https://www.suse.com/security/cve/CVE-2016-7444.html
https://www.suse.com/security/cve/CVE-2016-8610.html
https://www.suse.com/security/cve/CVE-2017-5335.html
https://www.suse.com/security/cve/CVE-2017-5336.html
https://www.suse.com/security/cve/CVE-2017-5337.html
http://www.nessus.org/u?3498a949

Solution :

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product :

SUSE Linux Enterprise Software Development Kit 12-SP2:zypper in -t
patch SUSE-SLE-SDK-12-SP2-2017-177=1

SUSE Linux Enterprise Software Development Kit 12-SP1:zypper in -t
patch SUSE-SLE-SDK-12-SP1-2017-177=1

SUSE Linux Enterprise Server for Raspberry Pi 12-SP2:zypper in -t
patch SUSE-SLE-RPI-12-SP2-2017-177=1

SUSE Linux Enterprise Server 12-SP2:zypper in -t patch
SUSE-SLE-SERVER-12-SP2-2017-177=1

SUSE Linux Enterprise Server 12-SP1:zypper in -t patch
SUSE-SLE-SERVER-12-SP1-2017-177=1

SUSE Linux Enterprise Desktop 12-SP2:zypper in -t patch
SUSE-SLE-DESKTOP-12-SP2-2017-177=1

SUSE Linux Enterprise Desktop 12-SP1:zypper in -t patch
SUSE-SLE-DESKTOP-12-SP1-2017-177=1

To bring your system up-to-date, use 'zypper patch'.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 5.5
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: SuSE Local Security Checks

Nessus Plugin ID: 96950 ()

Bugtraq ID:

CVE ID: CVE-2016-7444
CVE-2016-8610
CVE-2017-5335
CVE-2017-5336
CVE-2017-5337

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now