openSUSE Security Update : seamonkey (openSUSE-2017-189)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for SeaMonkey to version 2.46 fixes security issues and
bugs.

The following vulnerabilities were fixed :

- Fix all Gecko related security issues between 43.0.1 and
49.0.2

- CVE-2016-6354: buffer overrun in flex (boo#990856)

The following non-security changes are included :

- improve recognition of LANGUAGE env variable
(boo#1017174)

- improve TLS compatibility with certain websites
(boo#1021636)

- SeaMonkey now requires NSPR 4.12 and NSS 3.25

- based on Gecko 49.0.2

- Chatzilla and DOM Inspector were disabled

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1017174
https://bugzilla.opensuse.org/show_bug.cgi?id=1021636
https://bugzilla.opensuse.org/show_bug.cgi?id=984637
https://bugzilla.opensuse.org/show_bug.cgi?id=990856

Solution :

Update the affected seamonkey packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 96942 ()

Bugtraq ID:

CVE ID: CVE-2016-6354

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now