This script is Copyright (C) 2017 Tenable Network Security, Inc.
A PHP application running on the remote web server is affected by
According to its self-reported version number, the WordPress
application running on the remote web server is 4.7.x prior to 4.7.2.
It is, therefore, affected by multiple vulnerabilities :
- An information disclosure vulnerability exists in the
class-wp-press-this.php script due to a failure to
properly restrict the user interface for assigning
taxonomy terms. An authenticated, remote attacker can
exploit this to disclose sensitive information.
- A SQL injection (SQLi) vulnerability exists in the
class-wp-query.php script due to a failure to sanitize
input to post type names. An unauthenticated, remote
attacker can exploit this to inject or manipulate SQL
queries in the back-end database, resulting in the
disclosure or manipulation of arbitrary data.
- A cross-site scripting (XSS) vulnerability exists in the
class-wp-posts-list-table.php script due to improper
validation of input to the posts list table. An
unauthenticated, remote attacker can exploit this, via a
specially crafted request, to execute arbitrary script
code in a user's browser session. (CVE-2017-5612)
- A privilege escalation vulnerability exists in the REST
API due to a failure to properly sanitize user-supplied
input to the 'id' parameter when editing or deleting
blog posts. An unauthenticated, remote attacker can
exploit this issue to run arbitrary PHP code, inject
content into blog posts, modify blog post attributes, or
delete blog posts. (CVE-2017-1001000)
Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.
See also :
Upgrade to WordPress version 4.7.2 or later.
Risk factor :
High / CVSS Base Score : 7.5
CVSS Temporal Score : 6.2
Public Exploit Available : true