Wireshark 2.0.x < 2.0.10 / 2.2.x < 2.2.4 Multiple DoS (macOS)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An application installed on the remote macOS or Mac OS X host is
affected by multiple denial of service vulnerabilities.

Description :

The version of Wireshark installed on the remote macOS or Mac OS X
host is 2.0.x prior to 2.0.10 or 2.2.x prior to 2.2.4. It is,
therefore, affected by multiple denial of service vulnerabilities :

- A denial of service vulnerability exists when handling
DHCPv6 packets due to an integer overflow condition in
file epan/dissectors/packet-dhcpv6.c. An
unauthenticated, remote attacker can exploit this to
cause the program to enter a large loop that consumes
excessive CPU resources. (VulnDB 150784)

- A denial of service vulnerability exists in the
asterix_fspec_len() function within file
epan/dissectors/packet-asterix.c due to an infinite loop
flaw that is triggered because certain input is
improperly validated. An unauthenticated, remote
attacker can exploit this to consume excessive CPU
resources. (VulnDB 150785)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://www.wireshark.org/security/wnpa-sec-2017-01.html
https://www.wireshark.org/security/wnpa-sec-2017-02.html

Solution :

Upgrade to Wireshark version 2.0.10 / 2.2.4 or later.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)
CVSS Temporal Score : 4.1
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 96764 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now