openSUSE Security Update : gstreamer-plugins-bad (openSUSE-2017-84)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for gstreamer-plugins-bad fixes the following issues :

- CVE-2016-9809: Off by one read in
gst_h264_parse_set_caps() (bsc#1013659).

- CVE-2016-9812: Out of bounds read in
gst_mpegts_section_new (bsc#1013678).

- CVE-2016-9813: mpegts parser: NULL pointer deref in
_parse_pat (bsc#1013680).

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1013659
https://bugzilla.opensuse.org/show_bug.cgi?id=1013678
https://bugzilla.opensuse.org/show_bug.cgi?id=1013680

Solution :

Update the affected gstreamer-plugins-bad packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 96550 ()

Bugtraq ID:

CVE ID: CVE-2016-9809
CVE-2016-9812
CVE-2016-9813

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now