GLSA-201701-33 : PostgreSQL: Multiple vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201701-33
(PostgreSQL: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.

Impact :

A remote attacker could possibly execute arbitrary code with the
privileges of the process, cause a Denial of Service condition, or
escalate privileges.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201701-33

Solution :

All PostgreSQL 9.5.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>=dev-db/postgresql-9.5.4:9.5'
All PostgreSQL 9.4.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>dev-db/postgresql-9.4.9:9.4'
All PostgreSQL 9.3.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>dev-db/postgresql-9.3.14:9.3'
All PostgreSQL 9.2.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>dev-db/postgresql-9.2.18:9.2'
All PostgreSQL 9.1.x users should upgrade to the latest version:
# emerge --sync
# emerge --ask --oneshot --verbose '>dev-db/postgresql-9.1.23:9.1'

Risk factor :

High / CVSS Base Score : 9.0
(CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 96474 ()

Bugtraq ID:

CVE ID: CVE-2015-5288
CVE-2015-5289
CVE-2016-0766
CVE-2016-0773
CVE-2016-5423
CVE-2016-5424

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now