ImageMagick 6.x < 6.9.7-3 ReadPSDLayers() Function PSB File Handling RCE

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

An application installed on the remote Windows host is affected by a
remote code execution vulnerability.

Description :

The version of ImageMagick installed on the remote Windows host is 6.x
prior to 6.9.7-3. It is, therefore, affected by a remote code
execution vulnerability in the ReadPSDLayers() function in psd.c due
to improper validation of PSB files. An unauthenticated, remote
attacker can exploit this, by convincing a user to open a specially
crafted PSD file, to cause a denial of service condition or the
execution of arbitrary code.

See also :

https://github.com/ImageMagick/ImageMagick/issues/347

Solution :

Upgrade to ImageMagick version 6.9.7-3 or later. Note that you may
also need to manually uninstall the vulnerable version from the
system.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 96446 ()

Bugtraq ID:

CVE ID:

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now