Adobe Flash Player for Mac <= 24.0.0.186 Multiple Vulnerabilities (APSB17-02)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote macOS or Mac OS X host has a browser plugin installed that
is affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote macOS or Mac
OS X host is equal or prior to version 24.0.0.186. It is, therefore,
affected by multiple vulnerabilities :

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-2925, CVE-2017-2926, CVE-2017-2928,
CVE-2017-2930, CVE-2017-2931)

- Multiple heap buffer overflow conditions exist that
allow an unauthenticated, remote attacker to execute
arbitrary code. (CVE-2017-2927, CVE-2017-2933,
CVE-2017-2934, CVE-2017-2935)

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2017-2932, CVE-2017-2936, CVE-2017-2937)

- A security bypass vulnerability exists that allows an
unauthenticated, remote attacker to disclose sensitive
information. (CVE-2017-2938)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb17-02.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 24.0.0.194 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now