openSUSE Security Update : gstreamer-plugins-bad (openSUSE-2017-63)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for gstreamer-plugins-bad fixes the following security
issues, which would allow attackers able to submit media files for
indexing to cause code execution or crashes :

- Check an integer overflow (CVE-2016-9445) and initialize
a buffer (CVE-2016-9446) in vmncdec. (bsc#1010829)

- CVE-2016-9809: Ensure codec_data has the right size when
reading number of SPS (bsc#1013659).

- CVE-2016-9812: Add more section size checks
(bsc#1013678).

- CVE-2016-9813: fix PAT parsing (bsc#1013680).

This update was imported from the SUSE:SLE-12-SP2:Update update
project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1010829
https://bugzilla.opensuse.org/show_bug.cgi?id=1013659
https://bugzilla.opensuse.org/show_bug.cgi?id=1013678
https://bugzilla.opensuse.org/show_bug.cgi?id=1013680

Solution :

Update the affected gstreamer-plugins-bad packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 96382 ()

Bugtraq ID:

CVE ID: CVE-2016-9445
CVE-2016-9446
CVE-2016-9809
CVE-2016-9812
CVE-2016-9813

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now