openSUSE Security Update : ImageMagick (openSUSE-2017-14)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for ImageMagick fixes the following issues :

- CVE-2016-9556 Possible Heap-overflow found by fuzzing
[bsc#1011130]

- CVE-2016-9559 Possible NULL pointer access found by
fuzzing [bsc#1011136]

- CVE-2016-8707 Possible code execution in Tiff conver
utility [bsc#1014159]

- CVE-2016-8866 Memory allocation failure in
AcquireMagickMemory could lead to Heap overflow
[bsc#1009318]

- CVE-2016-9559 Possible NULL pointer access found by
fuzzing [bsc#1011136]

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1009318
https://bugzilla.opensuse.org/show_bug.cgi?id=1011130
https://bugzilla.opensuse.org/show_bug.cgi?id=1011136
https://bugzilla.opensuse.org/show_bug.cgi?id=1013376
https://bugzilla.opensuse.org/show_bug.cgi?id=1014159

Solution :

Update the affected ImageMagick packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 96296 ()

Bugtraq ID:

CVE ID: CVE-2014-9848
CVE-2016-8707
CVE-2016-8866
CVE-2016-9556
CVE-2016-9559
CVE-2016-9773

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now