openSUSE Security Update : wget (openSUSE-2017-9)

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for wget fixes the following issues :

Security issues fixed :

- CVE-2016-7098: Fixed a potential race condition by
creating files with .tmp ext and making them accessible
to the current user only. (bsc#995964)

Non security issues fixed :

- bsc#1005091: Don't call xfree() on string returned by
usr_error()

- bsc#1012677: Add support for enforcing TLSv1.1 and
TLSv1.2 (TLS 1.2 support was already present, but it was
not enforcable).

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1005091
https://bugzilla.opensuse.org/show_bug.cgi?id=1012677
https://bugzilla.opensuse.org/show_bug.cgi?id=995964

Solution :

Update the affected wget packages.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 96278 ()

Bugtraq ID:

CVE ID: CVE-2016-7098

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now