GLSA-201612-53 : CyaSSL: Multiple vulnerabilities

This script is Copyright (C) 2017 Tenable Network Security, Inc.


Synopsis :

The remote Gentoo host is missing one or more security-related
patches.

Description :

The remote host is affected by the vulnerability described in GLSA-201612-53
(CyaSSL: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in CyaSSL. Please review
the CVE identifiers referenced below for details.

Impact :

An attacker could possibly execute arbitrary code with the privileges of
the process, cause a Denial of Service condition, or conduct a
man-in-the-middle attack.

Workaround :

There is no known workaround at this time.

See also :

https://security.gentoo.org/glsa/201612-53

Solution :

Upstream has discontinued the software in favor of wolfSSL. Therefore,
the CyaSSL package has been removed from the Gentoo repository and
current users are advised to unmerge the package.
# emerge --unmerge 'net-libs/cyassl'

Risk factor :

Medium / CVSS Base Score : 5.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N)

Family: Gentoo Local Security Checks

Nessus Plugin ID: 96228 ()

Bugtraq ID:

CVE ID: CVE-2014-2896
CVE-2014-2897
CVE-2014-2898
CVE-2014-2899
CVE-2014-2900

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now