Adobe Flash Player <= 23.0.0.207 Multiple Vulnerabilities (APSB16-39)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Windows host
is equal or prior to version 23.0.0.207. It is, therefore, affected by
multiple vulnerabilities :

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-7872, CVE-2016-7877, CVE-2016-7878,
CVE-2016-7879, CVE-2016-7880, CVE-2016-7881,
CVE-2016-7892)

- Multiple buffer overflow conditions exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-7867, CVE-2016-7868, CVE-2016-7869,
CVE-2016-7870)

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-7871, CVE-2016-7873, CVE-2016-7874,
CVE-2016-7875, CVE-2016-7876)

- An unspecified security bypass vulnerability exists.
(CVE-2016-7890)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb16-39.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 24.0.0.186 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.7
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now