ImageMagick 7.x < 7.0.3-9 ReadSGIImage() SGI File Handling DoS

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

An application installed on the remote Windows host is affected by a
denial of service vulnerability.

Description :

The version of ImageMagick installed on the remote Windows host is 7.x
prior to 7.0.3-9. It is, therefore, affected by a denial of service
vulnerability due to an out-of-bounds read error in the ReadSGIImage()
function within file coders/sgi.c when handling iris info dimensions.
An unauthenticated, remote attacker can exploit this to crash a
process linked against the library or possibly disclose memory
contents.

Note that CVE-2016-9773 exists due to an incomplete fix for
CVE-2016-9556.

See also :

https://github.com/ImageMagick/ImageMagick/issues/301
https://github.com/ImageMagick/ImageMagick/issues/312
http://seclists.org/oss-sec/2016/q4/469
http://seclists.org/oss-sec/2016/q4/550

Solution :

Upgrade to ImageMagick version 7.0.3-9 or later. Note that you may
also need to manually uninstall the vulnerable version from the
system.

Risk factor :

High / CVSS Base Score : 7.8
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:C)
CVSS Temporal Score : 6.1
(CVSS2#E:POC/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 95722 ()

Bugtraq ID: 94492

CVE ID: CVE-2016-9556
CVE-2016-9773

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now