VMware vCenter Server 5.5.x < 5.5u3e / 6.0.x < 6.0u2a Multiple XXE Vulnerabilities (VMSA-2016-0022)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

A virtualization management application installed on the remote host
is affected by multiple XML external entity (XXE) vulnerabilities.

Description :

The version of VMware vCenter Server installed on the remote host is
5.5.x prior to 5.5u3e or 6.0.x prior to 6.0u2a. It is, therefore,
affected by multiple XML external entity (XXE) vulnerabilities :

- Multiple XML external entity (XXE) vulnerabilities exist
in the Log Browser, the Distributed Switch setup, and
the Content Library due to an incorrectly configured XML
parser accepting XML external entities from an untrusted
source. An authenticated, remote attacker can exploit
this, via specially crafted XML data, to disclose the
contents of arbitrary files. (CVE-2016-7459)

- An XML external entity (XXE) vulnerability exists in the
Single Sign-On functionality due to an incorrectly
configured XML parser accepting XML external entities
from an untrusted source. An unauthenticated, remote
attacker can exploit this, via specially crafted XML
data, to disclose the contents of arbitrary files or
cause a denial of service condition. (CVE-2016-7460)

See also :

https://www.vmware.com/security/advisories/VMSA-2016-0022.html

Solution :

Upgrade to VMware vCenter Server version 5.5.u3e (5.5.0 build-4180646)
/ 6.0u2a (6.0.0 build-4541947) or later.

Risk factor :

Medium / CVSS Base Score : 6.4
(CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:P)
CVSS Temporal Score : 5.3
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 95468 ()

Bugtraq ID: 94485
94486

CVE ID: CVE-2016-7459
CVE-2016-7460

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now