Apache Tomcat 6.0.x < 6.0.48 / 7.0.x < 7.0.73 / 8.0.x < 8.0.39 / 8.5.x < 8.5.8 Multiple Vulnerabilities

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.

Synopsis :

The remote Apache Tomcat server is affected by multiple

Description :

According to its self-reported version number, the Apache Tomcat
service running on the remote host is 6.0.x prior to 6.0.48, 7.0.x
prior to 7.0.73, 8.0.x prior to 8.0.39, or 8.5.x prior to 8.5.8. It
is, therefore, affected by multiple vulnerabilities :

- A flaw exists that is triggered when handling request
lines containing certain invalid characters. An
unauthenticated, remote attacker can exploit this, by
injecting additional headers into responses, to conduct
HTTP response splitting attacks. (CVE-2016-6816)

- A denial of service vulnerability exists in the HTTP/2
parser due to an infinite loop caused by improper
parsing of overly large headers. An unauthenticated,
remote attacker can exploit this, via a specially
crafted request, to cause a denial of service condition.
Note that this vulnerability only affects 8.5.x
versions. (CVE-2016-6817)

- A remote code execution vulnerability exists in the JMX
listener in JmxRemoteLifecycleListener.java due to
improper deserialization of Java objects. An
unauthenticated, remote attacker can exploit this to
execute arbitrary code. (CVE-2016-8735)

Note that Nessus has not attempted to exploit these issues but has
instead relied only on the application's self-reported version number.

See also :


Solution :

Upgrade to Apache Tomcat version 6.0.48 / 7.0.73 / 8.0.39 / 8.5.8 or

Risk factor :

Critical / CVSS Base Score : 10.0
CVSS Temporal Score : 7.4
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 95438 ()

Bugtraq ID: 94097

CVE ID: CVE-2016-6816

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now