ImageMagick 7.x < 7.0.3-6 WaveletDenoiseImage() Heap Buffer Overflow RCE

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

An application installed on the remote Windows host is affected by a
remote code execution vulnerability.

Description :

The version of ImageMagick installed on the remote Windows host is 7.x
prior to 7.0.3-6. It is, therefore, affected by a heap buffer overflow
condition in the WaveletDenoiseImage() function within file
MagicCore/fx.c. An unauthenticated, remote attacker can exploit this
to cause a denial of service condition or the execution of arbitrary
code.

See also :

https://github.com/ImageMagick/ImageMagick/issues/296
http://seclists.org/oss-sec/2016/q4/413

Solution :

Upgrade to ImageMagick version 7.0.3-6 or later. Note that you may
also need to manually uninstall the vulnerable version from the
system.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Windows

Nessus Plugin ID: 95319 ()

Bugtraq ID: 94310

CVE ID: CVE-2016-9298

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now