Adobe Flash Player for Mac <= 23.0.0.205 Multiple Vulnerabilities (APSB16-37)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote macOS or Mac OS X host has a browser plugin installed that
is affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote macOS or Mac
OS X host is equal or prior to version 23.0.0.205. It is, therefore,
affected by multiple vulnerabilities :

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code by convincing a user to visit a website containing
specially crafted Flash content. (CVE-2016-7857,
CVE-2016-7858, CVE-2016-7859, CVE-2016-7862,
CVE-2016-7863, CVE-2016-7864)

- Multiple type confusion errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code by convincing a user to visit a website containing
specially crafted Flash content. (CVE-2016-7860,
CVE-2016-7861, CVE-2016-7865)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb16-37.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 23.0.0.207 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Family: MacOS X Local Security Checks

Nessus Plugin ID: 94629 ()

Bugtraq ID: 94151
94153

CVE ID: CVE-2016-7857
CVE-2016-7858
CVE-2016-7859
CVE-2016-7860
CVE-2016-7861
CVE-2016-7862
CVE-2016-7863
CVE-2016-7864
CVE-2016-7865

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now