Apache Tomcat 6.0.x < 6.0.47 / 7.0.x < 7.0.72 / 8.0.x < 8.0.37 / 8.5.x < 8.5.5 Multiple Vulnerabilities

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Apache Tomcat server is affected by multiple
vulnerabilities.

Description :

According to its self-reported version number, the Apache Tomcat
service running on the remote host is 6.0.x prior to 6.0.47, 7.0.x
prior to 7.0.72, 8.0.x prior to 8.0.37, or 8.5.x prior to 8.5.5. It
is, therefore, affected by multiple vulnerabilities :

- An information disclosure vulnerability exists due to a
failure to process passwords when paired with a
non-existent username. An unauthenticated, remote
attacker can exploit this, via a timing attack, to
enumerate user account names. (CVE-2016-0762)

- A security bypass vulnerability exists that allows a
local attacker to bypass a configured SecurityManager
via a utility method that is accessible to web
applications. (CVE-2016-5018)

- An information disclosure vulnerability exists in the
SecurityManager component due to a failure to properly
restrict access to system properties for the
configuration files system property replacement feature.
An attacker can exploit this, via a specially crafted
web application, to bypass SecurityManager restrictions
and disclose system properties. (CVE-2016-6794)

- A security bypass vulnerability exists that allows a
local attacker to bypass a configured SecurityManager by
changing the configuration parameters for a JSP servlet.
(CVE-2016-6796)

- A security bypass vulnerability exists due to a failure
to limit web application access to global JNDI
resources. A local attacker can exploit this to gain
unauthorized access to resources. (CVE-2016-6797)

Note that Nessus has not attempted to exploit these issues but has
instead relied only on the application's self-reported version number.

See also :

http://www.nessus.org/u?5c3fa418
http://www.nessus.org/u?be50738a
http://www.nessus.org/u?47795ca8

Solution :

Upgrade to Apache Tomcat version 6.0.47 / 7.0.72 / 8.0.37 / 8.5.5 or
later. Note that versions 6.0.46 and 7.0.71 also resolve the
vulnerabilities; however, these versions were never officially
released by the vendor.

Risk factor :

Medium / CVSS Base Score : 4.3
(CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N)
CVSS Temporal Score : 3.2
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 94578 ()

Bugtraq ID: 93939
93940
93942
93943
93944

CVE ID: CVE-2016-0762
CVE-2016-5018
CVE-2016-6794
CVE-2016-6796
CVE-2016-6797

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now