openSUSE Security Update : openslp (openSUSE-2016-1262)

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for openslp fixes two security issues and two bugs.

The following vulnerabilities were fixed :

- CVE-2016-4912: A remote attacker could have crashed the
server with a large number of packages (bsc#980722)

- CVE-2016-7567: A remote attacker could cause a memory
corruption having unspecified impact (bsc#1001600)

The following bugfix changes are included :

- bsc#994989: Removed convenience code as changes bytes in
the message buffer breaking the verification code

- bsc#974655: Removed no longer needed slpd init file

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1001600
https://bugzilla.opensuse.org/show_bug.cgi?id=974655
https://bugzilla.opensuse.org/show_bug.cgi?id=980722
https://bugzilla.opensuse.org/show_bug.cgi?id=994989

Solution :

Update the affected openslp packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 94531 ()

Bugtraq ID:

CVE ID: CVE-2016-4912
CVE-2016-7567

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now