IBM WebSphere Application Server 7.0 < 7.0.0.43 / 8.0 < 8.0.0.13 / 8.5 < 8.5.5.11 / 9.0 < 9.0.0.2 Multiple Vulnerabilities

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

The remote web application server is affected by multiple
vulnerabilities.

Description :

The IBM WebSphere Application Server running on the remote host is
version 7.0 prior to 7.0.0.43, 8.0 prior to 8.0.0.13, 8.5 prior to
8.5.5.11, or 9.0 prior to 9.0.0.2. It is, therefore, affected by
multiple vulnerabilities :

- A remote code execution vulnerability exists due to
improper sanitization user-supplied input when
deserializing Java objects. An authenticated, remote
attacker can exploit this, via a crafted serialized
object, to execute arbitrary Java code. (CVE-2016-5983)

- An information disclosure vulnerability exists due to
improper handling of responses. An unauthenticated,
remote attacker can exploit this to disclose sensitive
server identification information. (CVE-2016-5986)

See also :

http://www-01.ibm.com/support/docview.wss?uid=swg21990056
http://www-01.ibm.com/support/docview.wss?uid=swg21990060

Solution :

Apply IBM WebSphere Application Server version 7.0 Fix Pack 43
(7.0.0.43) / 8.0 Fix Pack 13 (8.0.0.13) / 8.5 Fix Pack 11 (8.5.5.11) /
9.0 Fix Pack 2 (9.0.0.2) or later. Alternatively, apply Interim Fixes
PI67093 and PI70737.

Risk factor :

Medium / CVSS Base Score : 6.5
(CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P)
CVSS Temporal Score : 4.8
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: Web Servers

Nessus Plugin ID: 94512 ()

Bugtraq ID: 93013
93162

CVE ID: CVE-2016-5983
CVE-2016-5986

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now