openSUSE Security Update : irssi (openSUSE-2016-2524)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

The IRC client irssi was updated to 0.8.20, fixing various bugs and
security issues.

- CVE-2016-7044: The unformat_24bit_color function in the
format parsing code in Irssi, when compiled with
true-color enabled, allowed remote attackers to cause a
denial of service (heap corruption and crash) via an
incomplete 24bit color code.

- CVE-2016-7045: The format_send_to_gui function in the
format parsing code in Irssi allowed remote attackers to
cause a denial of service (heap corruption and crash)
via vectors involving the length of a string.

See https://irssi.org/security/irssi_sa_2016.txt for more details.

- CVE-2016-7553: A information disclosure vulnerability in
irssi buf.pl

See https://irssi.org/2016/09/22/buf.pl-update/ for more information.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=1001215
https://bugzilla.opensuse.org/show_bug.cgi?id=999199
https://irssi.org/2016/09/22/buf.pl-update/
https://irssi.org/security/irssi_sa_2016.txt

Solution :

Update the affected irssi packages.

Risk factor :

Medium / CVSS Base Score : 5.0
(CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 94093 ()

Bugtraq ID:

CVE ID: CVE-2016-7044
CVE-2016-7045
CVE-2016-7553

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now