Adobe Flash Player <= 23.0.0.162 Multiple Vulnerabilities (APSB16-32)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Windows host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Windows host
is equal or prior to version 23.0.0.162. It is, therefore, affected by
multiple vulnerabilities :

- A type confusion error exists that allows an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-6992)

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-6981, CVE-2016-6987)

- An unspecified security bypass vulnerability exists that
allows an unauthenticated, remote attacker to bypass
security restrictions. (CVE-2016-4286)

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-4273, CVE-2016-6982, CVE-2016-6983,
CVE-2016-6984, CVE-2016-6985, CVE-2016-6986,
CVE-2016-6989, CVE-2016-6990)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb16-32.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 23.0.0.185 or later.

Alternatively, Adobe has made version 18.0.0.382 available for those
installs that cannot be upgraded to the latest version.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now