openSUSE Security Update : perl (openSUSE-2016-1086)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update for Perl fixes the following issues :

- CVE-2016-6185: Xsloader looking at a '(eval)' directory.
(bsc#988311)

- CVE-2016-1238: Searching current directory for optional
modules. (bsc#987887)

- CVE-2015-8853: Regular expression engine hanging on bad
utf8. (bsc)

- CVE-2016-2381: Environment dup handling bug.
(bsc#967082)

- 'Insecure dependency in require' error in taint mode.
(bsc#984906)

- Memory leak in 'use utf8' handling. (bsc#928292)

- Missing lock prototype to the debugger. (bsc#932894)

This update was imported from the SUSE:SLE-12:Update update project.

See also :

https://bugzilla.opensuse.org/show_bug.cgi?id=928292
https://bugzilla.opensuse.org/show_bug.cgi?id=932894
https://bugzilla.opensuse.org/show_bug.cgi?id=967082
https://bugzilla.opensuse.org/show_bug.cgi?id=984906
https://bugzilla.opensuse.org/show_bug.cgi?id=987887
https://bugzilla.opensuse.org/show_bug.cgi?id=988311

Solution :

Update the affected perl packages.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)

Family: SuSE Local Security Checks

Nessus Plugin ID: 93583 ()

Bugtraq ID:

CVE ID: CVE-2015-8853
CVE-2016-1238
CVE-2016-2381
CVE-2016-6185

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now