Adobe Digital Editions < 4.5.2 Multiple Vulnerabilities (APSB16-28) (Mac OS X)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host is affected by multiple vulnerabilities.

Description :

The version of Adobe Digital Editions installed on the remote Mac OS
X host is prior to 4.5.2. It is, therefore, affected by multiple
vulnerabilities :

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-4256, CVE-2016-4257, CVE-2016-4258,
CVE-2016-4259, CVE-2016-4260, CVE-2016-4261,
CVE-2016-4262)

- A use-after-free error exists that allows an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-4263)

See also :

http://www.nessus.org/u?fee76481
http://www.nessus.org/u?c3aa2f29

Solution :

Upgrade to Adobe Digital Editions version 4.5.2 or later.

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.9
(CVSS2#E:U/RL:OF/RC:C)
Public Exploit Available : false

Family: MacOS X Local Security Checks

Nessus Plugin ID: 93514 ()

Bugtraq ID: 92925
92928

CVE ID: CVE-2016-4256
CVE-2016-4257
CVE-2016-4258
CVE-2016-4259
CVE-2016-4260
CVE-2016-4261
CVE-2016-4262
CVE-2016-4263

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now