Adobe Flash Player for Mac <= 22.0.0.211 Multiple Vulnerabilities (APSB16-29)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote Mac OS X host has a browser plugin installed that is
affected by multiple vulnerabilities.

Description :

The version of Adobe Flash Player installed on the remote Mac OS X
host is equal or prior to version 22.0.0.211. It is, therefore,
affected by multiple vulnerabilities :

- Multiple security bypass vulnerabilities exist that
allow an unauthenticated, remote attacker to disclose
sensitive information. (CVE-2016-4271, CVE-2016-4277,
CVE-2016-4278)

- Multiple use-after-free errors exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-4272, CVE-2016-4279, CVE-2016-6921,
CVE-2016-6923, CVE-2016-6925, CVE-2016-6926,
CVE-2016-6927, CVE-2016-6929, CVE-2016-6930,
CVE-2016-6931, CVE-2016-6932)

- Multiple memory corruption issues exist that allow an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-4274, CVE-2016-4275, CVE-2016-4276,
CVE-2016-4280, CVE-2016-4281, CVE-2016-4282,
CVE-2016-4283, CVE-2016-4284, CVE-2016-4285,
CVE-2016-6922, CVE-2016-6924)

- An integer overflow condition exists that allows an
unauthenticated, remote attacker to execute arbitrary
code. (CVE-2016-4287)

See also :

https://helpx.adobe.com/security/products/flash-player/apsb16-29.html
http://www.nessus.org/u?0cb17c10

Solution :

Upgrade to Adobe Flash Player version 23.0.0.162 or later.

Alternatively, Adobe has made version 18.0.0.375 available for those
installs that cannot be upgraded to the latest version

Risk factor :

High / CVSS Base Score : 9.3
(CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 7.3
(CVSS2#E:POC/RL:OF/RC:C)
Public Exploit Available : true