Cisco AnyConnect Secure Mobility Client 4.2.x < 4.2.5015.0 / 4.3.x < 4.3.2039.0 Privilege Escalation Vulnerability

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

A VPN application installed on the remote host is affected by a
privilege escalation vulnerability.

Description :

The version of Cisco AnyConnect Secure Mobility Client installed on
the remote Windows host is 4.2.x prior to 4.2.5015.0 or 4.3.x prior
to 4.3.2039.0. It is, therefore, affected by a privilege escalation
vulnerability due to incomplete validation of path names and file
names at installation time. A local attacker can exploit this, via a
specially crafted INF file, to install and execute files on the
underlying host with SYSTEM level privileges.

See also :

http://www.nessus.org/u?d67b10be
https://bst.cloudapps.cisco.com/bugsearch/bug/CSCuz92464

Solution :

Upgrade to Cisco AnyConnect Secure Mobility Client version
4.2.5015.0 / 4.3.2039.0 or later.

Risk factor :

High / CVSS Base Score : 7.2
(CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C)
CVSS Temporal Score : 6.0
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Windows

Nessus Plugin ID: 93382 ()

Bugtraq ID: 92625

CVE ID: CVE-2016-6369

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now