openSUSE Security Update : Firefox (openSUSE-2016-1019)

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote openSUSE host is missing a security update.

Description :

This update includes Firefox 48.0.1 to fix a few regressions and a
security issue :

- Fix an audio regression impacting some major websites

- Fix a top crash in the JavaScript engine

- Fix a startup crash issue caused by Websense

- Fix a different behavior with e10s / non-e10s on select
and mouse events

- Fix a top crash caused by plugin issues

- Fix a shutdown issue

- Fix a crash in WebRTC

- added upstream patch so system plugins/extensions are
correctly loaded again on x86-64

- Fix for possible buffer overrun

See also :

https://bugzilla.mozilla.org/show_bug.cgi?id=1264530
https://bugzilla.mozilla.org/show_bug.cgi?id=1276920
https://bugzilla.mozilla.org/show_bug.cgi?id=1282843
https://bugzilla.mozilla.org/show_bug.cgi?id=1290469
https://bugzilla.mozilla.org/show_bug.cgi?id=1291078
https://bugzilla.mozilla.org/show_bug.cgi?id=1291738
https://bugzilla.mozilla.org/show_bug.cgi?id=1292534
https://bugzilla.mozilla.org/show_bug.cgi?id=1295296
https://bugzilla.opensuse.org/show_bug.cgi?id=990856
https://bugzilla.opensuse.org/show_bug.cgi?id=992236

Solution :

Update the affected Firefox packages.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)

Family: SuSE Local Security Checks

Nessus Plugin ID: 93146 ()

Bugtraq ID:

CVE ID: CVE-2016-6354

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now