WordPress 4.5.x < 4.6 Multiple Vulnerabilities

This script is Copyright (C) 2016-2017 Tenable Network Security, Inc.


Synopsis :

A PHP application running on the remote web server is affected by
multiple vulnerabilities.

Description :

According to its self-reported version number, the WordPress
application running on the remote web server is 4.5.x prior to 4.6. It
is, therefore, affected by multiple vulnerabilities :

- A path traversal vulnerability exists in the WordPress
Admin API in the wp_ajax_update_plugin() function in
ajax-actions.php due to improper sanitization of
user-supplied input. An authenticated, remote attacker
can exploit this, via a specially crafted request, to
cause a denial of service condition. (CVE-2016-6896)

- A cross-site request forgery vulnerability (XSRF) exists
in the admin-ajax.php script due to a failure to require
multiple steps, explicit confirmation, or a unique token
when performing certain sensitive actions. An
unauthenticated, remote attacker can exploit this, by
convincing a user to follow a specially crafted link, to
perform arbitrary AJAX updates. (CVE-2016-6897)

- An information disclosure vulnerability exists in the
wp_ajax_update_plugin() function in the ajax-actions.php
script due to performing a call to get_plug_data()
before checking capabilities. An authenticated, remote
attacker can exploit this to bypass intended read-access
restrictions, resulting in a disclosure of sensitive
information. (CVE-2016-10148)

Note that Nessus has not tested for these issues but has instead
relied only on the application's self-reported version number.

See also :

https://wordpress.org/news/2016/08/pepper/
http://seclists.org/fulldisclosure/2016/Aug/98

Solution :

Upgrade to WordPress version 4.6 or later.

Risk factor :

Medium / CVSS Base Score : 6.8
(CVSS2#AV:N/AC:L/Au:S/C:N/I:N/A:C)
CVSS Temporal Score : 5.6
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: CGI abuses

Nessus Plugin ID: 93111 ()

Bugtraq ID: 92572
92573

CVE ID: CVE-2016-6896
CVE-2016-6897
CVE-2016-10148

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now