Pgbouncer 1.6 Invalid User Authentication Bypass

This script is Copyright (C) 2016 Tenable Network Security, Inc.


Synopsis :

The remote database connection pooler is affected by an
authentication bypass vulnerability.

Description :

The version of Pgbouncer running on the remote host is affected by an
authentication bypass vulnerability due to a flaw in the
start_auth_request() function within file client.c when handling
requests for invalid users. A remote attacker can exploit this issue
to bypass authentication and log into PostgreSQL via Pgbouncer using a
random user name.

See also :

http://seclists.org/oss-sec/2015/q3/495
https://github.com/pgbouncer/pgbouncer/issues/69
http://www.nessus.org/u?342233a3

Solution :

Upgrade to Pgbouncer version 1.6.1 or later. Alternatively, disable
'auth_user' in the Pgbouncer configuration.

Risk factor :

High / CVSS Base Score : 7.5
(CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P)
CVSS Temporal Score : 6.2
(CVSS2#E:F/RL:OF/RC:ND)
Public Exploit Available : true

Family: Misc.

Nessus Plugin ID: 93006 ()

Bugtraq ID:

CVE ID: CVE-2015-6817

Ready to Amp Up Your Nessus Experience?

Get Nessus Professional to scan unlimited IPs, run compliance checks & more

Buy Nessus Professional Now